Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Tree View not Grouping

2 posts in XML Last posting was on 2009-09-01 03:08:33.0Z
Jim Kelly Posted on 2009-08-24 19:39:22.0Z
From: Jim Kelly <relkin@gmail.com>
Newsgroups: sybase.public.powerbuilder.xml
Subject: Tree View not Grouping
Date: Mon, 24 Aug 2009 12:39:22 -0700 (PDT)
Organization: http://groups.google.com
Lines: 7
Message-ID: <c032ca73-c8ea-4b01-bbaa-ca4306ada23c@l5g2000pra.googlegroups.com>
NNTP-Posting-Host: 158.145.240.100
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1251142762 12328 127.0.0.1 (24 Aug 2009 19:39:22 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 24 Aug 2009 19:39:22 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: l5g2000pra.googlegroups.com; posting-host=158.145.240.100; posting-account=aua3-woAAABcnQ2GutQj8cneBRy_uPCc
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!l5g2000pra.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.xml:1844
Article PK: 814371

I have a Powerbuilder treeview datawindow set up, but for some reason,
under certain circumstances, It does not group items when it is
supposed to. It groups everything else, same Query. Any one else run
into problems where the Treeview didn't group items it was supposed
to? If so, any suggestions on how to get around this bug.

Thanks!


Terry Dykstra Posted on 2009-09-01 03:08:33.0Z
From: Terry Dykstra <dontreply_tddykstra@forestoil.ca.x>
User-Agent: Thunderbird 2.0.0.23 (X11/20090817)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.xml
Subject: Re: Tree View not Grouping
References: <c032ca73-c8ea-4b01-bbaa-ca4306ada23c@l5g2000pra.googlegroups.com>
In-Reply-To: <c032ca73-c8ea-4b01-bbaa-ca4306ada23c@l5g2000pra.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a9c9031@forums-1-dub>
Date: 31 Aug 2009 20:08:33 -0700
X-Trace: forums-1-dub 1251774513 10.22.241.152 (31 Aug 2009 20:08:33 -0700)
X-Original-Trace: 31 Aug 2009 20:08:33 -0700, vip152.sybase.com
Lines: 12
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.xml:1848
Article PK: 767953

Do you have a proper sort on the datawindow itself (not in the sql)?

Terry Dykstra

Jim Kelly wrote:
> I have a Powerbuilder treeview datawindow set up, but for some reason,
> under certain circumstances, It does not group items when it is
> supposed to. It groups everything else, same Query. Any one else run
> into problems where the Treeview didn't group items it was supposed
> to? If so, any suggestions on how to get around this bug.
>
> Thanks!