Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Crash switching several databases at the same time

3 posts in General Discussion Last posting was on 2012-12-22 21:04:30.0Z
rjlpedrosa Posted on 2012-12-22 08:06:30.0Z
Sender: 221b.50d564dd.1804289383@sybase.com
From: rjlpedrosa
Newsgroups: sybase.public.rep-server
Subject: Crash switching several databases at the same time
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <50d56a05.23cb.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 22 Dec 2012 00:06:30 -0800
X-Trace: forums-1-dub 1356163590 172.20.134.41 (22 Dec 2012 00:06:30 -0800)
X-Original-Trace: 22 Dec 2012 00:06:30 -0800, 172.20.134.41
Lines: 83
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:9286
Article PK: 1158589

Hi,

I'm having problems with the switch of several databases
at the same time.

When I start all rep agents after the switch and/or
resume the all connections in one step, it crashes my Rep
Server with the error:

N. 2012/12/22 02:03:14. INTERNAL ERROR #23 DIST(102
SystemSACa.SystemSACs) - xec/dist.c(1877)
Failed to assert '(RSHandle->rs_sm) == ((void *)0)'
at 1877, '/generic/exec/dist.c'.
T. 2012/12/22 02:03:14. (134): Dumping memory trace.
T. 2012/12/22 02:03:14. (134): ***************STACK
TRACE***************
T. 2012/12/22 02:03:14. (134): *****thread DIST(102
SystemSACa.SystemSACs)*******
T. 2012/12/22 02:03:14. (134): pc: 0x00000000008b65a0 +
000000000000025f, dbg_dump_stack ()
T. 2012/12/22 02:03:14. (134): pc: 0x00000000006168cc +
00000000000001dd, exc__appDumpStack ()
T. 2012/12/22 02:03:14. (134): pc: 0x000000000061b562 +
0000000000000464, exc_terminate ()
T. 2012/12/22 02:03:14. (134): pc: 0x0000000000619a08 +
000000000000023f, exc_reraise_exception ()
T. 2012/12/22 02:03:14. (134): pc: 0x0000000000619c4a +
000000000000088c, exc_raise_exception ()
T. 2012/12/22 02:03:14. (134): pc: 0x000000000056670a +
000000000000114d, dist_wrapper ()
T. 2012/12/22 02:03:14. (134): pc: 0x0000000000a3b370 +
0000000000000116, srv__start_function ()
T. 2012/12/22 02:03:14. (134): pc: 0x00000000f073cdd0,
unknown dynamic function
T. 2012/12/22 02:03:14. (134): pc: 0x00000000f073cdd0,
unknown dynamic function
T. 2012/12/22 02:03:14. (134): Thread DIST(102
SystemSACa.SystemSACs) infected with signal 11.
T. 2012/12/22 02:03:14. (134): Internal error. Attempting to
produce a core file.

The workaround we have to use is to wait some seconds
before executing each start rep agent and resume connection:

#stop all rep agents in on step (each step separated by go)
#wait > 2s
#switch all 5 databases in one step (each step separated by
go)
#wait > 2s

sp_start_rep_agent OBO
go
#wait > 2 s
sp_start_rep_agent ServerCommon
go
sp_start_rep_agent SystemSAC
go
#wait > 2 s
sp_start_rep_agent QFCTL
go
sp_start_rep_agent master
go
#wait > 2 s

resume connection to ASCTEST01.OBO
go
#wait > 2 s
resume connection to ASCTEST01.SystemSAC
go
resume connection to ASCTEST01.ServerCommon
go
#wait > 2 s
resume connection to ASCTEST01.QFCTL
go
resume connection to ASCTEST01.master
go
#wait > 2s

As anyone had this problem before?
I'm using Rep Server 15.7.1 ESD1 with ASE 15.0.3 on SUSE
11 64bits.

Thanks


"Mark A. Parsons" <iron_horse Posted on 2012-12-22 16:31:27.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
Newsgroups: sybase.public.rep-server
Subject: Re: Crash switching several databases at the same time
References: <50d56a05.23cb.1681692777@sybase.com>
In-Reply-To: <50d56a05.23cb.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: avast! (VPS 121124-1, 11/24/2012), Outbound message
X-Antivirus-Status: Clean
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <50d5e05f$1@forums-1-dub>
Date: 22 Dec 2012 08:31:27 -0800
X-Trace: forums-1-dub 1356193887 172.20.134.152 (22 Dec 2012 08:31:27 -0800)
X-Original-Trace: 22 Dec 2012 08:31:27 -0800, vip152.sybase.com
Lines: 90
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:9287
Article PK: 1158590

I'd recommend you open a case with Sybase tech support.

FWIW, I work at clients where it's common to stop/start dozens of repagents (same PDS/PRS for all repagents) in quick
succession without any problems (not much different than what happens when starting up a dataserver with dozens of
repagents); though none of my clients are running RS 15.7.

On 12/22/2012 01:06, rjlpedrosa wrote:
> Hi,
>
> I'm having problems with the switch of several databases
> at the same time.
>
> When I start all rep agents after the switch and/or
> resume the all connections in one step, it crashes my Rep
> Server with the error:
>
> N. 2012/12/22 02:03:14. INTERNAL ERROR #23 DIST(102
> SystemSACa.SystemSACs) - xec/dist.c(1877)
> Failed to assert '(RSHandle->rs_sm) == ((void *)0)'
> at 1877, '/generic/exec/dist.c'.
> T. 2012/12/22 02:03:14. (134): Dumping memory trace.
> T. 2012/12/22 02:03:14. (134): ***************STACK
> TRACE***************
> T. 2012/12/22 02:03:14. (134): *****thread DIST(102
> SystemSACa.SystemSACs)*******
> T. 2012/12/22 02:03:14. (134): pc: 0x00000000008b65a0 +
> 000000000000025f, dbg_dump_stack ()
> T. 2012/12/22 02:03:14. (134): pc: 0x00000000006168cc +
> 00000000000001dd, exc__appDumpStack ()
> T. 2012/12/22 02:03:14. (134): pc: 0x000000000061b562 +
> 0000000000000464, exc_terminate ()
> T. 2012/12/22 02:03:14. (134): pc: 0x0000000000619a08 +
> 000000000000023f, exc_reraise_exception ()
> T. 2012/12/22 02:03:14. (134): pc: 0x0000000000619c4a +
> 000000000000088c, exc_raise_exception ()
> T. 2012/12/22 02:03:14. (134): pc: 0x000000000056670a +
> 000000000000114d, dist_wrapper ()
> T. 2012/12/22 02:03:14. (134): pc: 0x0000000000a3b370 +
> 0000000000000116, srv__start_function ()
> T. 2012/12/22 02:03:14. (134): pc: 0x00000000f073cdd0,
> unknown dynamic function
> T. 2012/12/22 02:03:14. (134): pc: 0x00000000f073cdd0,
> unknown dynamic function
> T. 2012/12/22 02:03:14. (134): Thread DIST(102
> SystemSACa.SystemSACs) infected with signal 11.
> T. 2012/12/22 02:03:14. (134): Internal error. Attempting to
> produce a core file.
>
> The workaround we have to use is to wait some seconds
> before executing each start rep agent and resume connection:
>
> #stop all rep agents in on step (each step separated by go)
> #wait> 2s
> #switch all 5 databases in one step (each step separated by
> go)
> #wait> 2s
>
> sp_start_rep_agent OBO
> go
> #wait> 2 s
> sp_start_rep_agent ServerCommon
> go
> sp_start_rep_agent SystemSAC
> go
> #wait> 2 s
> sp_start_rep_agent QFCTL
> go
> sp_start_rep_agent master
> go
> #wait> 2 s
>
> resume connection to ASCTEST01.OBO
> go
> #wait> 2 s
> resume connection to ASCTEST01.SystemSAC
> go
> resume connection to ASCTEST01.ServerCommon
> go
> #wait> 2 s
> resume connection to ASCTEST01.QFCTL
> go
> resume connection to ASCTEST01.master
> go
> #wait> 2s
>
> As anyone had this problem before?
> I'm using Rep Server 15.7.1 ESD1 with ASE 15.0.3 on SUSE
> 11 64bits.
>
> Thanks


rjlpedrosa Posted on 2012-12-22 21:04:30.0Z
Sender: 6367.50d6201e.1804289383@sybase.com
From: rjlpedrosa
Newsgroups: sybase.public.rep-server
Subject: Re: Crash switching several databases at the same time
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <50d6205e.6387.1681692777@sybase.com>
References: <50d5e05f$1@forums-1-dub>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 22 Dec 2012 13:04:30 -0800
X-Trace: forums-1-dub 1356210270 172.20.134.41 (22 Dec 2012 13:04:30 -0800)
X-Original-Trace: 22 Dec 2012 13:04:30 -0800, 172.20.134.41
Lines: 97
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:9288
Article PK: 1158591

Thanks I will do that.

Best Regards

> I'd recommend you open a case with Sybase tech support.
>
> FWIW, I work at clients where it's common to stop/start
> dozens of repagents (same PDS/PRS for all repagents) in
> quick succession without any problems (not much different
> than what happens when starting up a dataserver with
> dozens of repagents); though none of my clients are
> running RS 15.7.
>
> On 12/22/2012 01:06, rjlpedrosa wrote:
> > Hi,
> >
> > I'm having problems with the switch of several
> > databases at the same time.
> >
> > When I start all rep agents after the switch and/or
> > resume the all connections in one step, it crashes my
> > Rep Server with the error:
> >
> > N. 2012/12/22 02:03:14. INTERNAL ERROR #23 DIST(102
> > SystemSACa.SystemSACs) - xec/dist.c(1877)
> > Failed to assert '(RSHandle->rs_sm) == ((void
> > *)0)' at 1877, '/generic/exec/dist.c'.
> > T. 2012/12/22 02:03:14. (134): Dumping memory trace.
> > T. 2012/12/22 02:03:14. (134): ***************STACK
> > TRACE***************
> > T. 2012/12/22 02:03:14. (134): *****thread DIST(102
> > SystemSACa.SystemSACs)*******
> > T. 2012/12/22 02:03:14. (134): pc: 0x00000000008b65a0 +
> > 000000000000025f, dbg_dump_stack ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x00000000006168cc +
> > 00000000000001dd, exc__appDumpStack ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x000000000061b562 +
> > 0000000000000464, exc_terminate ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x0000000000619a08 +
> > 000000000000023f, exc_reraise_exception ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x0000000000619c4a +
> > 000000000000088c, exc_raise_exception ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x000000000056670a +
> > 000000000000114d, dist_wrapper ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x0000000000a3b370 +
> > 0000000000000116, srv__start_function ()
> > T. 2012/12/22 02:03:14. (134): pc: 0x00000000f073cdd0,
> > unknown dynamic function
> > T. 2012/12/22 02:03:14. (134): pc: 0x00000000f073cdd0,
> > unknown dynamic function
> > T. 2012/12/22 02:03:14. (134): Thread DIST(102
> > SystemSACa.SystemSACs) infected with signal 11.
> > T. 2012/12/22 02:03:14. (134): Internal error.
> > Attempting to produce a core file.
> >
> > The workaround we have to use is to wait some
> > seconds before executing each start rep agent and resume
> connection: >
> > #stop all rep agents in on step (each step separated by
> > go) #wait> 2s
> > #switch all 5 databases in one step (each step separated
> > by go)
> > #wait> 2s
> >
> > sp_start_rep_agent OBO
> > go
> > #wait> 2 s
> > sp_start_rep_agent ServerCommon
> > go
> > sp_start_rep_agent SystemSAC
> > go
> > #wait> 2 s
> > sp_start_rep_agent QFCTL
> > go
> > sp_start_rep_agent master
> > go
> > #wait> 2 s
> >
> > resume connection to ASCTEST01.OBO
> > go
> > #wait> 2 s
> > resume connection to ASCTEST01.SystemSAC
> > go
> > resume connection to ASCTEST01.ServerCommon
> > go
> > #wait> 2 s
> > resume connection to ASCTEST01.QFCTL
> > go
> > resume connection to ASCTEST01.master
> > go
> > #wait> 2s
> >
> > As anyone had this problem before?
> > I'm using Rep Server 15.7.1 ESD1 with ASE 15.0.3 on
> > SUSE 11 64bits.
> >
> > Thanks