I have an ancient version (10.1.0.1134) of PowerDesigner.
It still completely meets my needs.

My problem is this: I recently got a Windows 7 machine, and
PD doesn't work any more (details below). It worked fine on
XP and Vista.

Details: I have two installation CDs. The first installs
version 10.0; the second upgrades it to 10.1.0.1134. The
attached doc1.doc contains these numbered screen shots that
illustrate my problem:

1. I run the installation of 10.0. The install apparently
goes OK. But when I try to run PD, the startup banner shown
in this screen shot pops up, and it hangs there forever.
The Windows Task Manager (also shown in the screen shot)
indicates that a process named "pdshell10.exe *32" is still
running.
2. This shows that Windows thinks PD is an installed app.
3. I try to install the upgrade. The install process hangs
at this point.

If cancel out of the upgrade and try to run PD at this
point, it hangs the same way as shown in screen shot 1.

I'm a retiree; I use PD only to do pro bono work for
nonprofits. I can't afford the 4-digit prices to buy the
latest edition of PD. I have a number of complex data
models in PD that would be hard to re-create in some other
(cheaper or free) tool.

So my questions are:

1. How to get PD 10.x to run under Win 7?
2. If that's impossible, is there any way to get a free -
or, at least, more affordable - version of PD (perhaps some
legacy version that nobody with money wants any more?) that
I can install and run under Win 7, and that will work OK
with my existing models?

~ Thanks in advance for your help
~ Ken