Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Portal cannot connect to repository database

3 posts in General Discussion Last posting was on 2012-08-28 08:32:29.0Z
George McGeachie ( Posted on 2012-08-27 20:50:37.0Z
Sender: 150.503bdc20.1804289383@sybase.com
From: George McGeachie (@metadatajunkie)
Newsgroups: sybase.public.powerdesigner.general
Subject: Portal cannot connect to repository database
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <503bdd9d.1dd.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 27 Aug 2012 13:50:37 -0700
X-Trace: forums-1-dub 1346100637 172.20.134.41 (27 Aug 2012 13:50:37 -0700)
X-Original-Trace: 27 Aug 2012 13:50:37 -0700, 172.20.134.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerdesigner.general:30900
Article PK: 834273

I'm running PD 16.1, with a repository running in SQL
Anywhere 12 on the same machine. I have no problem
connecting to the repository (with OCDB), but the web portal
cannot connect to it.
I've tried re-installing both SQL Anywhere and the portal,
with no luck.
The portal uses JDBC (with JRE 6 installed in a sub-folder
of the portal folder). It's connecting to localhost port
2638, with the "com.sybase.jdbc3.jdbc.SybDriver" database
driver. The database user name and password are definitely
OK. Is there anything that can explain this failure to
connect?


schalmers Posted on 2012-08-28 03:54:53.0Z
Sender: 4ccd.503b32db.1804289383@sybase.com
From: schalmers
Newsgroups: sybase.public.powerdesigner.general
Subject: Re: Portal cannot connect to repository database
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <503c410d.215d.1681692777@sybase.com>
References: <503bdd9d.1dd.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 27 Aug 2012 20:54:53 -0700
X-Trace: forums-1-dub 1346126093 172.20.134.41 (27 Aug 2012 20:54:53 -0700)
X-Original-Trace: 27 Aug 2012 20:54:53 -0700, 172.20.134.41
Lines: 23
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerdesigner.general:30902
Article PK: 834279


> I'm running PD 16.1, with a repository running in SQL
> Anywhere 12 on the same machine. I have no problem
> connecting to the repository (with OCDB), but the web
> portal cannot connect to it.
> I've tried re-installing both SQL Anywhere and the portal,
> with no luck.
> The portal uses JDBC (with JRE 6 installed in a sub-folder
> of the portal folder). It's connecting to localhost port
> 2638, with the "com.sybase.jdbc3.jdbc.SybDriver" database
> driver. The database user name and password are definitely
> OK. Is there anything that can explain this failure to
> connect?

I had the exact same issue.

Make sure you have installed the 32bit version of SQL
Anywhere and not the 64bit version. Power Designer (and the
PD Portal) cannot connect (or it can, but then has serious
issues..) to 64bit ODBC DNS's.

I can now connect to the Repository from the Portal - but
nothing is display (hence why I stumbled across this issue
trying to find a resolution for my problem :)


Ondra D. Posted on 2012-08-28 08:32:29.0Z
Sender: 2c5c.503c8146.1804289383@sybase.com
From: Ondra D.
Newsgroups: sybase.public.powerdesigner.general
Subject: Re: Portal cannot connect to repository database
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <503c821d.2c8b.1681692777@sybase.com>
References: <503c410d.215d.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 28 Aug 2012 01:32:29 -0700
X-Trace: forums-1-dub 1346142749 172.20.134.41 (28 Aug 2012 01:32:29 -0700)
X-Original-Trace: 28 Aug 2012 01:32:29 -0700, 172.20.134.41
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerdesigner.general:30904
Article PK: 834280


> > I'm running PD 16.1, with a repository running in SQL
> > Anywhere 12 on the same machine. I have no problem
> > connecting to the repository (with OCDB), but the web
> > portal cannot connect to it.
> > I've tried re-installing both SQL Anywhere and the
> > portal, with no luck.
> > The portal uses JDBC (with JRE 6 installed in a
> > sub-folder of the portal folder). It's connecting to
> > localhost port 2638, with the
> > "com.sybase.jdbc3.jdbc.SybDriver" database driver. The
> > database user name and password are definitely OK. Is
> > there anything that can explain this failure to connect?
>
> I had the exact same issue.
>
> Make sure you have installed the 32bit version of SQL
> Anywhere and not the 64bit version. Power Designer (and
> the PD Portal) cannot connect (or it can, but then has
> serious issues..) to 64bit ODBC DNS's.
>
> I can now connect to the Repository from the Portal - but
> nothing is display (hence why I stumbled across this issue
> trying to find a resolution for my problem :)

I had the same problem (couldn`t see anything after login).
Make sure you have patched the portal installation as well.
At least this was solution for me.

Regards,
Ondrej Divis