Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

setting attribute options for CODE field

3 posts in General Discussion Last posting was on 2012-08-15 15:27:37.0Z
Brentm Posted on 2012-08-14 23:15:40.0Z
Sender: a9f.502adb7c.1804289383@sybase.com
From: Brentm
Newsgroups: sybase.public.powerdesigner.general
Subject: setting attribute options for CODE field
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <502adc1c.ad6.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 14 Aug 2012 16:15:40 -0700
X-Trace: forums-1-dub 1344986140 172.20.134.41 (14 Aug 2012 16:15:40 -0700)
X-Original-Trace: 14 Aug 2012 16:15:40 -0700, 172.20.134.41
Lines: 3
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerdesigner.general:30879
Article PK: 834256

Does anyone know how to set the CODE field to be MixedCase
instead of using_underscore in the entity attribute.
Using_Underscore is the default for the CODE field.


Brentm Posted on 2012-08-15 00:05:33.0Z
Sender: a9f.502adb7c.1804289383@sybase.com
From: BrentM
Newsgroups: sybase.public.powerdesigner.general
Subject: Re: setting attribute options for CODE field
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <502ae7cc.d5a.1681692777@sybase.com>
References: <502adc1c.ad6.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 14 Aug 2012 17:05:33 -0700
X-Trace: forums-1-dub 1344989133 172.20.134.41 (14 Aug 2012 17:05:33 -0700)
X-Original-Trace: 14 Aug 2012 17:05:33 -0700, 172.20.134.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerdesigner.general:30880
Article PK: 834259


> Does anyone know how to set the CODE field to be MixedCase
> instead of using_underscore in the entity attribute.
> Using_Underscore is the default for the CODE field.

I've worked it out... on the model Options - Naming
Conventions - code tab and it was Mixed Case and I changed
it to UpperCamelCase.

How can I fix these settings for all future models -via a
template?
How do I do that - sybooks is so out of date and you can't
find anything and the material isn't very good.