Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Why db replication can't support create proxy_table?

6 posts in General Discussion Last posting was on 2011-09-19 02:20:54.0Z
Eisen Posted on 2011-09-15 03:17:23.0Z
Sender: 3ae4.4e715b1d.1804289383@sybase.com
From: Eisen
Newsgroups: sybase.public.rep-server
Subject: Why db replication can't support create proxy_table?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e716e43.3f9f.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Sep 2011 20:17:23 -0700
X-Trace: forums-1-dub 1316056643 10.22.241.41 (14 Sep 2011 20:17:23 -0700)
X-Original-Trace: 14 Sep 2011 20:17:23 -0700, 10.22.241.41
Lines: 24
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:9049
Article PK: 870214

Dear sirs
I've built a test environment of two db replications by
warm-standby via logical connection on a RS15.6 on AIX.
I tested "create table","drop table"... all successful,
but when I tested --
1. create proxy_table pr at
'prod.fawpmpr0.dbo.CMC_MEME_MEMBER'
2. create proxy_table pr at
"prod.fawpmpr0.dbo.CMC_MEME_MEMBER'
the RS failed by error report --

E. 2011/09/15 10:55:07. ERROR #1028 DSI EXEC(106(1)
sybwpmdr00.fawpmmo0xc) - dsiqmint.c(4292)
Message from server: Message: 102, State 1, Severity
15 -- 'Incorrect syntax near '.'.'.
H. 2011/09/15 10:55:07. THREAD FATAL ERROR #5049 DSI
EXEC(106(1) sybwpmdr00.fawpmmo0xc) - dsiqmint.c(4305)


I have no idea on this. Would anyone kind to give me
some advice? Thanks in advance for any help...

Best Regards
Eisen


"Mark A. Parsons" <iron_horse Posted on 2011-09-15 17:59:08.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
Newsgroups: sybase.public.rep-server
Subject: Re: Why db replication can't support create proxy_table?
References: <4e716e43.3f9f.1681692777@sybase.com>
In-Reply-To: <4e716e43.3f9f.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e723cec@forums-1-dub>
Date: 15 Sep 2011 10:59:08 -0700
X-Trace: forums-1-dub 1316109548 10.22.241.152 (15 Sep 2011 10:59:08 -0700)
X-Original-Trace: 15 Sep 2011 10:59:08 -0700, vip152.sybase.com
Lines: 35
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:9050
Article PK: 870217

You've provided what appears to be a pair of identical 'create proxy_table' commands ... but since you got the
single/double quotes mixed up I'm wondering if you cut-n-pasted the wrong commands? Can you verify the 1 (2?) commands
you're trying to test?

Could you also log the exception to your RSSD and then post back here with the complete dump of said exception? (I'd
like to see what exactly the DSI is trying to apply against the RDB.)

Have you by any chance made any changes to the function string class for this particular DSI connection?

Have you ever had the 'create proxy_table' command work successfully in a warm standby configuration and if so, what
version(s) of ASE and RS?

On 09/14/2011 23:17, Eisen wrote:
> Dear sirs
> I've built a test environment of two db replications by
> warm-standby via logical connection on a RS15.6 on AIX.
> I tested "create table","drop table"... all successful,
> but when I tested --
> 1. create proxy_table pr at 'prod.fawpmpr0.dbo.CMC_MEME_MEMBER'
> 2. create proxy_table pr at "prod.fawpmpr0.dbo.CMC_MEME_MEMBER'
> the RS failed by error report --
>
> E. 2011/09/15 10:55:07. ERROR #1028 DSI EXEC(106(1)
> sybwpmdr00.fawpmmo0xc) - dsiqmint.c(4292)
> Message from server: Message: 102, State 1, Severity
> 15 -- 'Incorrect syntax near '.'.'.
> H. 2011/09/15 10:55:07. THREAD FATAL ERROR #5049 DSI
> EXEC(106(1) sybwpmdr00.fawpmmo0xc) - dsiqmint.c(4305)
>
>
> I have no idea on this. Would anyone kind to give me
> some advice? Thanks in advance for any help...
>
> Best Regards
> Eisen


Eisen Posted on 2011-09-16 03:31:13.0Z
Sender: 3ae4.4e715b1d.1804289383@sybase.com
From: Eisen
Newsgroups: sybase.public.rep-server
Subject: Re: Why db replication can't support create proxy_table?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e72c301.973.1681692777@sybase.com>
References: <4e723cec@forums-1-dub>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-1-dub4e72c301"
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 15 Sep 2011 20:31:13 -0700
X-Trace: forums-1-dub 1316143873 10.22.241.41 (15 Sep 2011 20:31:13 -0700)
X-Original-Trace: 15 Sep 2011 20:31:13 -0700, 10.22.241.41
Lines: 1430
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:9051
Article PK: 870254

Thanks a lot for your kind reply.
1. yes. I made mistake in single/double quotes in second
statement. But when I tried in both double quotes, it also
failed and raised the same error.

I tested again today by -- create proxy_table pr at
"prod.fawpmpr0.dbo.CMC_MEME_MEMBER" . it failed again as
usual. -- and for your second question , I have never
succesfully creating proxy_table in warm-standby system. :-(
So I dumped the queue contains error command and the
errorlog in attachment. Please have a check.
Thanks again for your help

Best Regards
Eisen

> You've provided what appears to be a pair of identical
> 'create proxy_table' commands ... but since you got the
> single/double quotes mixed up I'm wondering if you
> cut-n-pasted the wrong commands? Can you verify the 1 (2?)
> commands you're trying to test?
>
> Could you also log the exception to your RSSD and then
> post back here with the complete dump of said exception?
> (I'd like to see what exactly the DSI is trying to apply
> against the RDB.)
>
> Have you by any chance made any changes to the function
> string class for this particular DSI connection?
>
> Have you ever had the 'create proxy_table' command work
> successfully in a warm standby configuration and if so,
> what version(s) of ASE and RS?
>
> On 09/14/2011 23:17, Eisen wrote:
> > Dear sirs
> > I've built a test environment of two db replications
> > by warm-standby via logical connection on a RS15.6 on
> > AIX. I tested "create table","drop table"... all
> > successful, but when I tested --
> > 1. create proxy_table pr at
> > 'prod.fawpmpr0.dbo.CMC_MEME_MEMBER' 2. create
> > proxy_table pr at
> "prod.fawpmpr0.dbo.CMC_MEME_MEMBER' the RS failed by error
> report -- >
> > E. 2011/09/15 10:55:07. ERROR #1028 DSI EXEC(106(1)
> > sybwpmdr00.fawpmmo0xc) - dsiqmint.c(4292)
> > Message from server: Message: 102, State 1,
> > Severity 15 -- 'Incorrect syntax near '.'.'.
> > H. 2011/09/15 10:55:07. THREAD FATAL ERROR #5049 DSI
> > EXEC(106(1) sybwpmdr00.fawpmmo0xc) - dsiqmint.c(4305)
> >
> >
> > I have no idea on this. Would anyone kind to give
> > me some advice? Thanks in advance for any help...
> >
> > Best Regards
> > Eisen