Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Uncomplete ::: Drop Route

4 posts in General Discussion Last posting was on 2011-07-18 16:30:59.0Z
Sergio Diogo Posted on 2011-07-18 13:31:30.0Z
Sender: 6ea1.4e2433c7.1804289383@sybase.com
From: Sergio Diogo
Newsgroups: sybase.public.rep-server
Subject: Uncomplete ::: Drop Route
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e2435b2.6ee6.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 18 Jul 2011 06:31:30 -0700
X-Trace: forums-1-dub 1310995890 10.22.241.41 (18 Jul 2011 06:31:30 -0700)
X-Original-Trace: 18 Jul 2011 06:31:30 -0700, 10.22.241.41
Lines: 23
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:8994
Article PK: 841872

Hi,

I had to drop a route due to a replication server that was
inadvertently decommissioned.

After dropping the route with nowait I have performed the
sysadmin droprs and sysadmin dropdb.

On the RSSD server I got this insert:
insert rs_segments
(partition_id,q_number,q_type,partition_offset,logical_seg,used_flag
,version,flags ) values (105,0,0,146,0,0,4,0 )

that failed.

So currently the queue still not free of data that was to be
applied to the deco rep server and I still have an RSI
thread to that deco rep server being showed as inactive.

How can I complete the task of dropping the route? any idea?

Regards,
Sergio


Manish Negandhi [TeamSybase] Posted on 2011-07-18 16:08:39.0Z
From: "Manish Negandhi [TeamSybase]" <nospam_negandhi.manish@gmail.com>
Newsgroups: sybase.public.rep-server
References: <4e2435b2.6ee6.1681692777@sybase.com>
Subject: Re: Uncomplete ::: Drop Route
Lines: 36
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3664
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3664
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e245a87@forums-1-dub>
Date: 18 Jul 2011 09:08:39 -0700
X-Trace: forums-1-dub 1311005319 10.22.241.152 (18 Jul 2011 09:08:39 -0700)
X-Original-Trace: 18 Jul 2011 09:08:39 -0700, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:8995
Article PK: 870158


<Sergio Diogo> wrote in message news:4e2435b2.6ee6.1681692777@sybase.com...
> Hi,
>
> I had to drop a route due to a replication server that was
> inadvertently decommissioned.
>
> After dropping the route with nowait I have performed the
> sysadmin droprs and sysadmin dropdb.
>
> On the RSSD server I got this insert:
> insert rs_segments
> (partition_id,q_number,q_type,partition_offset,logical_seg,used_flag
> ,version,flags ) values (105,0,0,146,0,0,4,0 )
> > that failed.

Why do you want to insert in rs_segment directly ? what is that you are
trying to do here and also post the error what you are getting ..

>
> So currently the queue still not free of data that was to be
> applied to the deco rep server and I still have an RSI
> thread to that deco rep server being showed as inactive.
> > How can I complete the task of dropping the route? any idea?
> > Regards,
> Sergio

You can always purge the queue using sysadmin sqm_purge_queue

-HTH
Manish Negandhi
[TeamSybase]


Sérgio Diogo Posted on 2011-07-18 16:18:04.0Z
Sender: 6ea1.4e2433c7.1804289383@sybase.com
From: S=?ISO-8859-1?B?6XJnaW8=?= Diogo
Newsgroups: sybase.public.rep-server
Subject: Re: Uncomplete ::: Drop Route
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e245cbc.77c1.1681692777@sybase.com>
References: <4e245a87@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 18 Jul 2011 09:18:04 -0700
X-Trace: forums-1-dub 1311005884 10.22.241.41 (18 Jul 2011 09:18:04 -0700)
X-Original-Trace: 18 Jul 2011 09:18:04 -0700, 10.22.241.41
Lines: 43
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:8996
Article PK: 870162

what about the RSI inactive to a replication server that no
longer exists?

Sergio

> <Sergio Diogo> wrote in message
> > news:4e2435b2.6ee6.1681692777@sybase.com... Hi,
> >
> > I had to drop a route due to a replication server that
> > was inadvertently decommissioned.
> >
> > After dropping the route with nowait I have performed
> > the sysadmin droprs and sysadmin dropdb.
> >
> > On the RSSD server I got this insert:
> > insert rs_segments
> > (partition_id,q_number,q_type,partition_offset
> > ,logical_seg,used_flag ,version,flags ) values
> > > (105,0,0,146,0,0,4,0 ) that failed.
>
> Why do you want to insert in rs_segment directly ? what is
> that you are trying to do here and also post the error
> what you are getting ..
>
> >
> > So currently the queue still not free of data that was
> > to be applied to the deco rep server and I still have an
> > RSI thread to that deco rep server being showed as
> > > inactive. How can I complete the task of dropping the
> > > route? any idea? Regards,
> > Sergio
>
> You can always purge the queue using sysadmin
> sqm_purge_queue
>
> -HTH
> Manish Negandhi
> [TeamSybase]
>
>
>
>


Manish Negandhi [TeamSybase] Posted on 2011-07-18 16:30:59.0Z
From: "Manish Negandhi [TeamSybase]" <nospam_negandhi.manish@gmail.com>
Newsgroups: sybase.public.rep-server
References: <4e245a87@forums-1-dub> <4e245cbc.77c1.1681692777@sybase.com>
Subject: Re: Uncomplete ::: Drop Route
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3664
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3664
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e245fc3@forums-1-dub>
Date: 18 Jul 2011 09:30:59 -0700
X-Trace: forums-1-dub 1311006659 10.22.241.152 (18 Jul 2011 09:30:59 -0700)
X-Original-Trace: 18 Jul 2011 09:30:59 -0700, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-server:8997
Article PK: 870159


"S érgio Diogo" <S =?ISO-8859-1?B?6XJnaW8=?= Diogo> wrote in message
news:4e245cbc.77c1.1681692777@sybase.com...
> what about the RSI inactive to a replication server that no
> longer exists?
>
> Sergio
>

You can try deleting those entries from rs_routes table , after
deletion..reboot the repserver. As always take a backup of RSSD before doing
any changes !

-HTH
Manish Negandhi
[TeamSybase]