Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Can not connect to Ultralite database

8 posts in Ultralite Last posting was on 2011-04-04 13:54:15.0Z
frank Posted on 2011-03-31 08:51:55.0Z
Sender: 226.4d943dab.1804289383@sybase.com
From: Frank
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Can not connect to Ultralite database
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4d9440ab.2a4.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 31 Mar 2011 00:51:55 -0800
X-Trace: forums-1-dub 1301561515 10.22.241.41 (31 Mar 2011 00:51:55 -0800)
X-Original-Trace: 31 Mar 2011 00:51:55 -0800, 10.22.241.41
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12452
Article PK: 1048272

With Sybase Central I can not connect to an ultralite
database.
Even when I create a new one, I can not connect to it. I
always get the message 'data source name is not found and no
default driver specified' (SQLCODE=0, SQLSTATE=IM002)

I'm running Sybase Central version 6.1.0.6420 on a Windows 7
64-bit system. And Ultralite 12 (12.0.1.3152)à is
installed.

I did try to reinstall Sybase central and terminated the
running instances (as described in the documentation), but
without success

Anyone any ideas?


Chris Keating (Sybase, an SAP Company) Posted on 2011-03-31 12:16:28.0Z
From: "Chris Keating (Sybase, an SAP Company)" <last_name@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9
MIME-Version: 1.0
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Re: Can not connect to Ultralite database
References: <4d9440ab.2a4.1681692777@sybase.com>
In-Reply-To: <4d9440ab.2a4.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d94709c$1@forums-1-dub>
Date: 31 Mar 2011 04:16:28 -0800
X-Trace: forums-1-dub 1301573788 10.22.241.152 (31 Mar 2011 04:16:28 -0800)
X-Original-Trace: 31 Mar 2011 04:16:28 -0800, vip152.sybase.com
Lines: 28
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12453
Article PK: 1048214

This means that the UL ODBC driver (used by the admin tools) is not
installed.

Open a command prompt and execute:

regsvr32 %sqlany12%\bin32\ulodbc12.dll
regsvr32 %sqlany12%\bin64\ulodbc12.dll

-chris

On 3/31/2011 4:51 AM, Frank wrote:
> With Sybase Central I can not connect to an ultralite
> database.
> Even when I create a new one, I can not connect to it. I
> always get the message 'data source name is not found and no
> default driver specified' (SQLCODE=0, SQLSTATE=IM002)
>
> I'm running Sybase Central version 6.1.0.6420 on a Windows 7
> 64-bit system. And Ultralite 12 (12.0.1.3152)à is
> installed.
>
> I did try to reinstall Sybase central and terminated the
> running instances (as described in the documentation), but
> without success
>
> Anyone any ideas?


Chris Keating (Sybase, an SAP Company) Posted on 2011-03-31 12:19:49.0Z
From: "Chris Keating (Sybase, an SAP Company)" <last_name@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9
MIME-Version: 1.0
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Re: Can not connect to Ultralite database
References: <4d9440ab.2a4.1681692777@sybase.com>
In-Reply-To: <4d9440ab.2a4.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d947165$1@forums-1-dub>
Date: 31 Mar 2011 04:19:49 -0800
X-Trace: forums-1-dub 1301573989 10.22.241.152 (31 Mar 2011 04:19:49 -0800)
X-Original-Trace: 31 Mar 2011 04:19:49 -0800, vip152.sybase.com
Lines: 22
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12454
Article PK: 1048215

Can you provide a little background on what specifically you installed.
i.e. what options were selected during the initial install.

-chris

On 3/31/2011 4:51 AM, Frank wrote:
> With Sybase Central I can not connect to an ultralite
> database.
> Even when I create a new one, I can not connect to it. I
> always get the message 'data source name is not found and no
> default driver specified' (SQLCODE=0, SQLSTATE=IM002)
>
> I'm running Sybase Central version 6.1.0.6420 on a Windows 7
> 64-bit system. And Ultralite 12 (12.0.1.3152)à is
> installed.
>
> I did try to reinstall Sybase central and terminated the
> running instances (as described in the documentation), but
> without success
>
> Anyone any ideas?


frank Posted on 2011-03-31 13:36:52.0Z
Sender: 226.4d943dab.1804289383@sybase.com
From: Frank
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Re: Can not connect to Ultralite database
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4d948374.c39.1681692777@sybase.com>
References: <4d947165$1@forums-1-dub>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 31 Mar 2011 05:36:52 -0800
X-Trace: forums-1-dub 1301578612 10.22.241.41 (31 Mar 2011 05:36:52 -0800)
X-Original-Trace: 31 Mar 2011 05:36:52 -0800, 10.22.241.41
Lines: 49
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12455
Article PK: 1048218

Chris,

Thanks for the quick response. Registering the dll solved my
problem.

To answer your question about installation options: I just
installed Sql Anywhere 12 with the default options (I
verified that Ultralite was also selected and it's selected
by default, so no changes were needed).

I think it has something to do with the latest version of
Sybase Central because last year in September, I did install
it also without any problems (on the same machine, also
Windows 7 64-bit). I suppose it was an earlier version,
because I don't have that installation file anymore and did
download the latest one.
Or maybe it has something to do with SP1 of Windows 7. I did
try installing Sybase Central also 'as administrator', also
without success

Regards

Frank

> Can you provide a little background on what specifically
> you installed. i.e. what options were selected during the
> initial install.
>
> -chris
>
> On 3/31/2011 4:51 AM, Frank wrote:
> > With Sybase Central I can not connect to an ultralite
> > database.
> > Even when I create a new one, I can not connect to it. I
> > always get the message 'data source name is not found
> > and no default driver specified' (SQLCODE=0,
> SQLSTATE=IM002) >
> > I'm running Sybase Central version 6.1.0.6420 on a
> > Windows 7 64-bit system. And Ultralite 12
(12.0.1.3152)à
> > is installed.
> >
> > I did try to reinstall Sybase central and terminated the
> > running instances (as described in the documentation),
> > but without success
> >
> > Anyone any ideas?
>


Chris Keating (Sybase, an SAP Company) Posted on 2011-03-31 14:38:44.0Z
From: "Chris Keating (Sybase, an SAP Company)" <last_name@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9
MIME-Version: 1.0
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Re: Can not connect to Ultralite database
References: <4d947165$1@forums-1-dub> <4d948374.c39.1681692777@sybase.com>
In-Reply-To: <4d948374.c39.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d9491f4$1@forums-1-dub>
Date: 31 Mar 2011 06:38:44 -0800
X-Trace: forums-1-dub 1301582324 10.22.241.152 (31 Mar 2011 06:38:44 -0800)
X-Original-Trace: 31 Mar 2011 06:38:44 -0800, vip152.sybase.com
Lines: 55
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12456
Article PK: 1048219

Thanks

-chris

On 3/31/2011 9:36 AM, Frank wrote:
> Chris,
>
> Thanks for the quick response. Registering the dll solved my
> problem.
>
> To answer your question about installation options: I just
> installed Sql Anywhere 12 with the default options (I
> verified that Ultralite was also selected and it's selected
> by default, so no changes were needed).
>
> I think it has something to do with the latest version of
> Sybase Central because last year in September, I did install
> it also without any problems (on the same machine, also
> Windows 7 64-bit). I suppose it was an earlier version,
> because I don't have that installation file anymore and did
> download the latest one.
> Or maybe it has something to do with SP1 of Windows 7. I did
> try installing Sybase Central also 'as administrator', also
> without success
>
> Regards
>
> Frank
>
>
>> Can you provide a little background on what specifically
>> you installed. i.e. what options were selected during the
>> initial install.
>>
>> -chris
>>
>> On 3/31/2011 4:51 AM, Frank wrote:
>>> With Sybase Central I can not connect to an ultralite
>>> database.
>>> Even when I create a new one, I can not connect to it. I
>>> always get the message 'data source name is not found
>>> and no default driver specified' (SQLCODE=0,
>> SQLSTATE=IM002)>
>>> I'm running Sybase Central version 6.1.0.6420 on a
>>> Windows 7 64-bit system. And Ultralite 12
> (12.0.1.3152)à
>>> is installed.
>>>
>>> I did try to reinstall Sybase central and terminated the
>>> running instances (as described in the documentation),
>>> but without success
>>>
>>> Anyone any ideas?
>>

vo


Shao Chan Posted on 2011-04-04 09:10:47.0Z
Reply-To: "Shao Chan" <nospam@nospam.com>
From: "Shao Chan" <nospam@nospam.com>
Newsgroups: sybase.public.sqlanywhere.ultralite
References: <4d947165$1@forums-1-dub> <4d948374.c39.1681692777@sybase.com> <4d9491f4$1@forums-1-dub>
Subject: Re: Can not connect to Ultralite database
Lines: 71
Organization: Civica
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5994
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d997d07@forums-1-dub>
Date: 4 Apr 2011 01:10:47 -0800
X-Trace: forums-1-dub 1301904647 10.22.241.152 (4 Apr 2011 01:10:47 -0800)
X-Original-Trace: 4 Apr 2011 01:10:47 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12458
Article PK: 1048224

Hi Chris,

The solution to this problem seems to be the same as mine in thread:
"dbisql.com Ultralite read in file"
We are also running 64-bit and had the same problem. We also leave the
default options as they are during install.

Cheers,

Shao

"Chris Keating (Sybase, an SAP Company)" <last_name@sybase.com> wrote in
message news:4d9491f4$1@forums-1-dub...
> Thanks
>
> -chris
>
> On 3/31/2011 9:36 AM, Frank wrote:
>> Chris,
>>
>> Thanks for the quick response. Registering the dll solved my
>> problem.
>>
>> To answer your question about installation options: I just
>> installed Sql Anywhere 12 with the default options (I
>> verified that Ultralite was also selected and it's selected
>> by default, so no changes were needed).
>>
>> I think it has something to do with the latest version of
>> Sybase Central because last year in September, I did install
>> it also without any problems (on the same machine, also
>> Windows 7 64-bit). I suppose it was an earlier version,
>> because I don't have that installation file anymore and did
>> download the latest one.
>> Or maybe it has something to do with SP1 of Windows 7. I did
>> try installing Sybase Central also 'as administrator', also
>> without success
>>
>> Regards
>>
>> Frank
>>
>>
>>> Can you provide a little background on what specifically
>>> you installed. i.e. what options were selected during the
>>> initial install.
>>>
>>> -chris
>>>
>>> On 3/31/2011 4:51 AM, Frank wrote:
>>>> With Sybase Central I can not connect to an ultralite
>>>> database.
>>>> Even when I create a new one, I can not connect to it. I
>>>> always get the message 'data source name is not found
>>>> and no default driver specified' (SQLCODE=0,
>>> SQLSTATE=IM002)>
>>>> I'm running Sybase Central version 6.1.0.6420 on a
>>>> Windows 7 64-bit system. And Ultralite 12
>> (12.0.1.3152)à
>>>> is installed.
>>>>
>>>> I did try to reinstall Sybase central and terminated the
>>>> running instances (as described in the documentation),
>>>> but without success
>>>>
>>>> Anyone any ideas?
>>>
> vo


Chris Keating (Sybase, an SAP Company) Posted on 2011-04-04 12:54:31.0Z
From: "Chris Keating (Sybase, an SAP Company)" <last_name@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9
MIME-Version: 1.0
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Re: Can not connect to Ultralite database
References: <4d947165$1@forums-1-dub> <4d948374.c39.1681692777@sybase.com> <4d9491f4$1@forums-1-dub> <4d997d07@forums-1-dub>
In-Reply-To: <4d997d07@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d99bf87$1@forums-1-dub>
Date: 4 Apr 2011 05:54:31 -0700
X-Trace: forums-1-dub 1301921671 10.22.241.152 (4 Apr 2011 05:54:31 -0700)
X-Original-Trace: 4 Apr 2011 05:54:31 -0700, vip152.sybase.com
Lines: 78
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12459
Article PK: 1048222

This issue has been identified and resolved. The 64bit odbc driver was
not being registered correctly. Any EBF 3298 or later should resolve
this issue or you can manually register the driver.

On 4/4/2011 5:10 AM, Shao Chan wrote:
> Hi Chris,
>
> The solution to this problem seems to be the same as mine in thread:
> "dbisql.com Ultralite read in file"
> We are also running 64-bit and had the same problem. We also leave the
> default options as they are during install.
>
> Cheers,
>
> Shao
>
>
> "Chris Keating (Sybase, an SAP Company)"<last_name@sybase.com> wrote in
> message news:4d9491f4$1@forums-1-dub...
>> Thanks
>>
>> -chris
>>
>> On 3/31/2011 9:36 AM, Frank wrote:
>>> Chris,
>>>
>>> Thanks for the quick response. Registering the dll solved my
>>> problem.
>>>
>>> To answer your question about installation options: I just
>>> installed Sql Anywhere 12 with the default options (I
>>> verified that Ultralite was also selected and it's selected
>>> by default, so no changes were needed).
>>>
>>> I think it has something to do with the latest version of
>>> Sybase Central because last year in September, I did install
>>> it also without any problems (on the same machine, also
>>> Windows 7 64-bit). I suppose it was an earlier version,
>>> because I don't have that installation file anymore and did
>>> download the latest one.
>>> Or maybe it has something to do with SP1 of Windows 7. I did
>>> try installing Sybase Central also 'as administrator', also
>>> without success
>>>
>>> Regards
>>>
>>> Frank
>>>
>>>
>>>> Can you provide a little background on what specifically
>>>> you installed. i.e. what options were selected during the
>>>> initial install.
>>>>
>>>> -chris
>>>>
>>>> On 3/31/2011 4:51 AM, Frank wrote:
>>>>> With Sybase Central I can not connect to an ultralite
>>>>> database.
>>>>> Even when I create a new one, I can not connect to it. I
>>>>> always get the message 'data source name is not found
>>>>> and no default driver specified' (SQLCODE=0,
>>>> SQLSTATE=IM002)>
>>>>> I'm running Sybase Central version 6.1.0.6420 on a
>>>>> Windows 7 64-bit system. And Ultralite 12
>>> (12.0.1.3152)à
>>>>> is installed.
>>>>>
>>>>> I did try to reinstall Sybase central and terminated the
>>>>> running instances (as described in the documentation),
>>>>> but without success
>>>>>
>>>>> Anyone any ideas?
>>>>
>> vo
>
>


Shao Chan Posted on 2011-04-04 13:54:15.0Z
Reply-To: "Shao Chan" <nospam@nospam.com>
From: "Shao Chan" <nospam@nospam.com>
Newsgroups: sybase.public.sqlanywhere.ultralite
References: <4d947165$1@forums-1-dub> <4d948374.c39.1681692777@sybase.com> <4d9491f4$1@forums-1-dub> <4d997d07@forums-1-dub> <4d99bf87$1@forums-1-dub>
Subject: Re: Can not connect to Ultralite database
Lines: 90
Organization: Civica
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5994
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d99cd87@forums-1-dub>
Date: 4 Apr 2011 06:54:15 -0700
X-Trace: forums-1-dub 1301925255 10.22.241.152 (4 Apr 2011 06:54:15 -0700)
X-Original-Trace: 4 Apr 2011 06:54:15 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12460
Article PK: 1048221

Hi Chris,

Thanks for that.

Cheers,

Shao

"Chris Keating (Sybase, an SAP Company)" <last_name@sybase.com> wrote in
message news:4d99bf87$1@forums-1-dub...
> This issue has been identified and resolved. The 64bit odbc driver was
> not being registered correctly. Any EBF 3298 or later should resolve this
> issue or you can manually register the driver.
>
>
> On 4/4/2011 5:10 AM, Shao Chan wrote:
>> Hi Chris,
>>
>> The solution to this problem seems to be the same as mine in thread:
>> "dbisql.com Ultralite read in file"
>> We are also running 64-bit and had the same problem. We also leave the
>> default options as they are during install.
>>
>> Cheers,
>>
>> Shao
>>
>>
>> "Chris Keating (Sybase, an SAP Company)"<last_name@sybase.com> wrote in
>> message news:4d9491f4$1@forums-1-dub...
>>> Thanks
>>>
>>> -chris
>>>
>>> On 3/31/2011 9:36 AM, Frank wrote:
>>>> Chris,
>>>>
>>>> Thanks for the quick response. Registering the dll solved my
>>>> problem.
>>>>
>>>> To answer your question about installation options: I just
>>>> installed Sql Anywhere 12 with the default options (I
>>>> verified that Ultralite was also selected and it's selected
>>>> by default, so no changes were needed).
>>>>
>>>> I think it has something to do with the latest version of
>>>> Sybase Central because last year in September, I did install
>>>> it also without any problems (on the same machine, also
>>>> Windows 7 64-bit). I suppose it was an earlier version,
>>>> because I don't have that installation file anymore and did
>>>> download the latest one.
>>>> Or maybe it has something to do with SP1 of Windows 7. I did
>>>> try installing Sybase Central also 'as administrator', also
>>>> without success
>>>>
>>>> Regards
>>>>
>>>> Frank
>>>>
>>>>
>>>>> Can you provide a little background on what specifically
>>>>> you installed. i.e. what options were selected during the
>>>>> initial install.
>>>>>
>>>>> -chris
>>>>>
>>>>> On 3/31/2011 4:51 AM, Frank wrote:
>>>>>> With Sybase Central I can not connect to an ultralite
>>>>>> database.
>>>>>> Even when I create a new one, I can not connect to it. I
>>>>>> always get the message 'data source name is not found
>>>>>> and no default driver specified' (SQLCODE=0,
>>>>> SQLSTATE=IM002)>
>>>>>> I'm running Sybase Central version 6.1.0.6420 on a
>>>>>> Windows 7 64-bit system. And Ultralite 12
>>>> (12.0.1.3152)à
>>>>>> is installed.
>>>>>>
>>>>>> I did try to reinstall Sybase central and terminated the
>>>>>> running instances (as described in the documentation),
>>>>>> but without success
>>>>>>
>>>>>> Anyone any ideas?
>>>>>
>>> vo
>>
>>
>