Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

special characters in XML File

3 posts in XML Last posting was on 2009-11-06 05:56:35.0Z
Ignacio Carrasquedo Posted on 2009-11-05 07:24:37.0Z
From: "Ignacio Carrasquedo" <icarrasquedo@hotmail.com>
Newsgroups: sybase.public.powerbuilder.xml
Subject: special characters in XML File
Lines: 109
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="----=_NextPart_000_0029_01CA5DB6.BA3BC230"
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4af27db5@forums-1-dub>
Date: 4 Nov 2009 23:24:37 -0800
X-Trace: forums-1-dub 1257405877 10.22.241.152 (4 Nov 2009 23:24:37 -0800)
X-Original-Trace: 4 Nov 2009 23:24:37 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.xml:1860
Article PK: 814389

Hi i'm exporting a datawindow to an XML File
what it seems to be done correctly , nevertheles the files never gets readed
using an hexagesimal editor i found 3 characters that where inserted at the
first characters of the file
after deleting it with an hex editor files get loaded with no problem


Hexagecimal characters are EF BB BF

i'm ataching the image


Is there a way to avoid then from be apearing on the file ??


Thanks

hexerror.jpg

Arthur Hefti Posted on 2009-11-05 13:28:31.0Z
From: "Arthur Hefti" <arthur@catsoft.ch>
Subject: Re: special characters in XML File
Newsgroups: sybase.public.powerbuilder.xml
References: <4af27db5@forums-1-dub>
User-Agent: XanaNews/1.19.1.194
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4af2d2ff$1@forums-1-dub>
Date: 5 Nov 2009 05:28:31 -0800
X-Trace: forums-1-dub 1257427711 10.22.241.152 (5 Nov 2009 05:28:31 -0800)
X-Original-Trace: 5 Nov 2009 05:28:31 -0800, vip152.sybase.com
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.xml:1861
Article PK: 814385

This is the Byte Order Mark (BOM) which identifies the type of encoding
your XML file uses. The BOM should be interpreted by the application
reading your file. Is it an external application or one written in PB?

Regards
Arthur

Ignacio Carrasquedo wrote:

> Hi i'm exporting a datawindow to an XML File
> what it seems to be done correctly , nevertheles the files never gets
> readed using an hexagesimal editor i found 3 characters that where
> inserted at the first characters of the file after deleting it with
> an hex editor files get loaded with no problem
>
>
> Hexagecimal characters are EF BB BF
>
> i'm ataching the image
>
>
> Is there a way to avoid then from be apearing on the file ??
>
>
> Thanks


Ignacio Carrasquedo Posted on 2009-11-06 05:56:35.0Z
From: "Ignacio Carrasquedo" <icarrasquedo@hotmail.com>
Newsgroups: sybase.public.powerbuilder.xml
References: <4af27db5@forums-1-dub> <4af2d2ff$1@forums-1-dub>
In-Reply-To: <4af2d2ff$1@forums-1-dub>
Subject: Re: special characters in XML File
Lines: 1
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 8bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4af3ba93$1@forums-1-dub>
Date: 5 Nov 2009 21:56:35 -0800
X-Trace: forums-1-dub 1257486995 10.22.241.152 (5 Nov 2009 21:56:35 -0800)
X-Original-Trace: 5 Nov 2009 21:56:35 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.xml:1862
Article PK: 814383

it's a 3rd party external application , is there a way to avoid this codes
??


"Arthur Hefti" <arthur@catsoft.ch> escribió en el mensaje de
noticias:4af2d2ff$1@forums-1-dub...

> This is the Byte Order Mark (BOM) which identifies the type of encoding
> your XML file uses. The BOM should be interpreted by the application
> reading your file. Is it an external application or one written in PB?
>
> Regards
> Arthur
>
> Ignacio Carrasquedo wrote:
>
>> Hi i'm exporting a datawindow to an XML File
>> what it seems to be done correctly , nevertheles the files never gets
>> readed using an hexagesimal editor i found 3 characters that where
>> inserted at the first characters of the file after deleting it with
>> an hex editor files get loaded with no problem
>>
>>
>> Hexagecimal characters are EF BB BF
>>
>> i'm ataching the image
>>
>>
>> Is there a way to avoid then from be apearing on the file ??
>>
>>
>> Thanks