Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

RepAgent for Oracle

2 posts in Replication Agent Last posting was on 2008-03-01 08:03:10.0Z
AWF Posted on 2008-02-25 21:19:28.0Z
Sender: 4fe2.47c32dad.1804289383@sybase.com
From: AWF
Newsgroups: sybase.public.rep-agent
Subject: RepAgent for Oracle
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <47c330e0.502c.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Feb 2008 13:19:28 -0800
X-Trace: forums-1-dub 1203974368 10.22.241.41 (25 Feb 2008 13:19:28 -0800)
X-Original-Trace: 25 Feb 2008 13:19:28 -0800, 10.22.241.41
Lines: 52
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:914
Article PK: 862483

I'm using RAX 15 and trying to setup replication from Oracle
10g. After trying to "Resume" the RA, the command line
states RAX goes into replication state. However, subsequent
status call identifies it's back in the admin state.

All trace flags are currently on. Error in the RAX log
dealing with errors follows:

T. 2008/02/22 20:42:29.964 RACONTRCSQL
com.sybase.ra.conn.RAConnection Executing
SQL:
T. 2008/02/22 20:42:29.964 RACONTRCSQL
com.sybase.ra.conn.RAConnection select
oracleUser from oracleUse
r where version in (select max(version) from oracleUser
group by userName) and userName='SA'
E. 2008/02/22 20:42:29.973 ERROR
com.sybase.ra.lr.oracle.RAOTranReader Unable to
configure log reader t
o filter maintenance user <sa> because: User with name <SA>
not found.
E. 2008/02/22 20:42:29.973 ERROR
com.sybase.ra.lr.oracle.RAOTranReader
com.sybase.ra.lr.TranReaderExcep
tion: Unable to configure log reader to filter maintenance
user <sa> because: User with name <SA> not found.
E. 2008/02/22 20:42:29.973 ERROR
com.sybase.ra.lr.oracle.RAOTranReader
com.sybase.ra.lr.oracle.
RAOTranReader.configureMaintenanceUser(RAOTranReader.java:1049)

T. 2008/02/22 20:42:30.148 LTMCI
com.sybase.ra.ltm.LTM
changeState(): LTM state has cha
nged. New state: Internal State: LR_ERROR, External State:
REPLICATING, State interpretation: Transitioning - LogReader
is stopping due
to error..: Event name: LR_ERROR, Event interpretation:
LogReader encountered an unexpected error.. Error Message:
Unable to configure l
og reader to filter maintenance user <sa> because: User with
name <SA> not found.


In review of my ra_config output, the only username I have
set to sa is for the function_username (I think this is the
default value).

Not sure what the problem is. Any help would be
appreciated...

awf-


Michael Peppler Posted on 2008-03-01 08:03:10.0Z
From: Michael Peppler <mpeppler@peppler.org>
Organization: Peppler Consulting SARL
Subject: Re: RepAgent for Oracle
User-Agent: Pan/0.14.2 (This is not a psychotic episode. It's a cleansing moment of clarity.)
Message-ID: <pan.2008.03.01.08.02.44.950566@peppler.org>
Newsgroups: sybase.public.rep-agent
References: <47c330e0.502c.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 1 Mar 2008 00:03:10 -0800
X-Trace: forums-1-dub 1204358590 10.22.241.152 (1 Mar 2008 00:03:10 -0800)
X-Original-Trace: 1 Mar 2008 00:03:10 -0800, vip152.sybase.com
Lines: 35
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:915
Article PK: 862489


On Mon, 25 Feb 2008 13:19:28 -0800, AWF wrote:

> I'm using RAX 15 and trying to setup replication from Oracle
> 10g. After trying to "Resume" the RA, the command line
> states RAX goes into replication state. However, subsequent
> status call identifies it's back in the admin state.
>
> All trace flags are currently on. Error in the RAX log
> dealing with errors follows:
>
> T. 2008/02/22 20:42:29.964 RACONTRCSQL
> com.sybase.ra.conn.RAConnection Executing
> SQL:
> T. 2008/02/22 20:42:29.964 RACONTRCSQL
> com.sybase.ra.conn.RAConnection select
> oracleUser from oracleUse
> r where version in (select max(version) from oracleUser
> group by userName) and userName='SA'
> E. 2008/02/22 20:42:29.973 ERROR
> com.sybase.ra.lr.oracle.RAOTranReader Unable to
> configure log reader t
> o filter maintenance user <sa> because: User with name <SA>
> not found.

I don't have the docs handy, but it looks like you haven't defined the
user that RAO should use to connect to the Oracle instance. It's
pds_user_name, or something like that.

Michael
--
Michael Peppler - Peppler Consulting SaRL
mpeppler@peppler.org - http://www.peppler.org
Sybase DBA/Developer - TeamSybase: http://www.teamsybase.com
Sybase on Linux FAQ - http://www.peppler.org/FAQ/linux.html