Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ads_connect hangs

3 posts in PHP Last posting was on 2008-01-29 17:08:52.0Z
Chuck Jopson Posted on 2008-01-29 16:42:59.0Z
Date: Tue, 29 Jan 2008 08:42:59 -0800
From: Chuck Jopson <chucknews@growpro-inc.com>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: advantage.PHP
Subject: ads_connect hangs
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 208.31.88.154
Message-ID: <479f56a8@solutions.advantagedatabase.com>
X-Trace: 29 Jan 2008 09:39:04 -0700, 208.31.88.154
Lines: 20
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!208.31.88.154
Xref: solutions.advantagedatabase.com Advantage.PHP:864
Article PK: 1135348

Running ADS 8.10.0.18 on Windows 2000 Server.
Using Apache 2.0 and PHP 5.2.4 with php_advantage.dll.5.2.3.

When running Apache as localhost on an XP PC, everything worked fine,
could access ADS running on the Win 2000 server.

When I run Apache/PHP as a service on the Win 2000 server, the
ads_connect call hangs. The ADS error log shows nothing. The website
code is unchanged from when it worked on the XP PC.

Ran Process Explorer and Apache is using ADSODBC.dll ver 8.10.0.18.
ADS.exe(also running as a service) is using ACE32.DLL ver 8.10.0.18.
Tried using both drive letter and url style connection string in
ads_connect().

Are there any other DLL versions I should check?
Any other config issues?

Thanks,
Chuck


Lance Schmidt Posted on 2008-01-29 16:58:06.0Z
From: "Lance Schmidt" <LanceSc@ExtendSys.com>
Newsgroups: advantage.PHP
References: <479f56a8@solutions.advantagedatabase.com>
Subject: Re: ads_connect hangs
Date: Tue, 29 Jan 2008 09:58:06 -0700
Lines: 36
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: 10.24.38.197
Message-ID: <479f59d3@solutions.advantagedatabase.com>
X-Trace: 29 Jan 2008 09:52:35 -0700, 10.24.38.197
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.197
Xref: solutions.advantagedatabase.com Advantage.PHP:866
Article PK: 1135350

Hi Chuck,

You will want to check that ace32.dll and axcws32.dll is available for the
adsodbc.dll to load. Most likely adsodbc.dll is not finding on of those two
DLLs.

Best Regards,

Lance Schmidt
Advantage R&D

"Chuck Jopson" <chucknews@growpro-inc.com> wrote in message
news:479f56a8@solutions.advantagedatabase.com...
> Running ADS 8.10.0.18 on Windows 2000 Server.
> Using Apache 2.0 and PHP 5.2.4 with php_advantage.dll.5.2.3.
>
> When running Apache as localhost on an XP PC, everything worked fine,
> could access ADS running on the Win 2000 server.
>
> When I run Apache/PHP as a service on the Win 2000 server, the ads_connect
> call hangs. The ADS error log shows nothing. The website code is unchanged
> from when it worked on the XP PC.
>
> Ran Process Explorer and Apache is using ADSODBC.dll ver 8.10.0.18.
> ADS.exe(also running as a service) is using ACE32.DLL ver 8.10.0.18.
> Tried using both drive letter and url style connection string in
> ads_connect().
>
> Are there any other DLL versions I should check?
> Any other config issues?
>
> Thanks,
> Chuck


Chuck Jopson Posted on 2008-01-29 17:08:52.0Z
Date: Tue, 29 Jan 2008 09:08:52 -0800
From: Chuck Jopson <chucknews@growpro-inc.com>
User-Agent: Thunderbird 2.0.0.9 (Windows/20071031)
MIME-Version: 1.0
Newsgroups: advantage.PHP
Subject: Re: ads_connect hangs
References: <479f56a8@solutions.advantagedatabase.com> <479f59d3@solutions.advantagedatabase.com>
In-Reply-To: <479f59d3@solutions.advantagedatabase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 208.31.88.154
Message-ID: <479f5cb4@solutions.advantagedatabase.com>
X-Trace: 29 Jan 2008 10:04:52 -0700, 208.31.88.154
Lines: 44
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!208.31.88.154
Xref: solutions.advantagedatabase.com Advantage.PHP:867
Article PK: 1135351

Lance,
Thanks! You think I would have that figured out by now!
Copied ver 8.10.0.18 ace32.dll and axcws32.dll to my WINNT directory and
it works fine!

Chuck

Lance Schmidt wrote:
> Hi Chuck,
>
> You will want to check that ace32.dll and axcws32.dll is available for the
> adsodbc.dll to load. Most likely adsodbc.dll is not finding on of those two
> DLLs.
>
> Best Regards,
>
> Lance Schmidt
> Advantage R&D
>
>
> "Chuck Jopson" <chucknews@growpro-inc.com> wrote in message
> news:479f56a8@solutions.advantagedatabase.com...
>> Running ADS 8.10.0.18 on Windows 2000 Server.
>> Using Apache 2.0 and PHP 5.2.4 with php_advantage.dll.5.2.3.
>>
>> When running Apache as localhost on an XP PC, everything worked fine,
>> could access ADS running on the Win 2000 server.
>>
>> When I run Apache/PHP as a service on the Win 2000 server, the ads_connect
>> call hangs. The ADS error log shows nothing. The website code is unchanged
>> from when it worked on the XP PC.
>>
>> Ran Process Explorer and Apache is using ADSODBC.dll ver 8.10.0.18.
>> ADS.exe(also running as a service) is using ACE32.DLL ver 8.10.0.18.
>> Tried using both drive letter and url style connection string in
>> ads_connect().
>>
>> Are there any other DLL versions I should check?
>> Any other config issues?
>>
>> Thanks,
>> Chuck
>
>