Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ADI Files Disappearing

2 posts in Xbase++ Last posting was on 2007-11-05 11:09:53.0Z
Asif Patel Posted on 2007-11-01 17:05:26.0Z
Reply-To: "Asif Patel" <asif.patel@ttc.ca>
From: "Asif Patel" <asif.patel@ttc.ca>
Newsgroups: Advantage.Xbase++
Subject: ADI Files Disappearing
Date: Thu, 1 Nov 2007 13:05:26 -0400
Lines: 9
Organization: TTC
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 206.186.8.130
Message-ID: <472a0619@solutions.advantagedatabase.com>
X-Trace: 1 Nov 2007 11:00:09 -0700, 206.186.8.130
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!206.186.8.130
Xref: solutions.advantagedatabase.com Advantage.Xbase++:847
Article PK: 1140713

I am a beginner with XBASE and I am trying to create an index on one of my
ADT(converted from dbf) file using XBASE. Code executes fine and creates the
index(ADI FILE) as well but for some reason it deletes the index right after
creating. Can anyone please help?

Thanks
Asif.


Joachim Duerr (ADS) Posted on 2007-11-05 11:09:53.0Z
From: "Joachim Duerr (ADS)" <jojo.duerr@gmx.de>
Subject: Re: ADI Files Disappearing
Newsgroups: Advantage.Xbase++
References: <472a0619@solutions.advantagedatabase.com>
Organization: iAnywhere
User-Agent: XanaNews/1.18.1.2
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 10.56.66.108
Message-ID: <472efa01@solutions.advantagedatabase.com>
Date: 5 Nov 2007 04:09:53 -0700
X-Trace: 5 Nov 2007 04:09:53 -0700, 10.56.66.108
Lines: 16
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.56.66.108
Xref: solutions.advantagedatabase.com Advantage.Xbase++:848
Article PK: 1140714


Asif Patel wrote in <472a0619@solutions.advantagedatabase.com>:

> I am a beginner with XBASE and I am trying to create an index on one
> of my ADT(converted from dbf) file using XBASE. Code executes fine
> and creates the index(ADI FILE) as well but for some reason it
> deletes the index right after creating. Can anyone please help?

are you connecting via a data dictionary? If so, if you don't provide a
valid user/password for an admin user, then the index is just a temp
index.

--
Joachim Duerr
System Consultant (Advantage Database Server)
Sybase iAnywhere
advantagesupport[AT]ianywhere.com