Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Server port <5552> is in use by another application.

4 posts in Replication Agent Last posting was on 2004-04-15 20:45:47.0Z
lnielsen Posted on 2004-04-14 16:26:42.0Z
Sender: 5fa4.407d575a.1804289383@sybase.com
From: LNielsen
Newsgroups: sybase.public.rep-agent
Subject: Server port <5552> is in use by another application.
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <407d582e.5fbb.846930886@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 14 Apr 2004 08:26:38 -0800, 10.22.241.42
Lines: 5
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 Apr 2004 08:26:39 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 Apr 2004 08:26:42 -0800
X-Trace: forums-1-dub 1081956402 10.22.108.75 (14 Apr 2004 08:26:42 -0800)
X-Original-Trace: 14 Apr 2004 08:26:42 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:671
Article PK: 862322

We had a problem with our with repagent. The stable queue
filled up and the server was shutdown. Now when we try to
restart, we get the message that the port is in use.

any ideas what we need to do to get the port freed?


Wanda Beck Posted on 2004-04-15 01:05:32.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.rep-agent
References: <407d582e.5fbb.846930886@sybase.com>
Subject: Re: Server port <5552> is in use by another application.
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1409
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1409
NNTP-Posting-Host: vpn-dub-055.sybase.com
X-Original-NNTP-Posting-Host: vpn-dub-055.sybase.com
Message-ID: <407dd1cc$1@forums-1-dub>
Date: 14 Apr 2004 17:05:32 -0800
X-Trace: forums-1-dub 1081987532 10.22.120.55 (14 Apr 2004 17:05:32 -0800)
X-Original-Trace: 14 Apr 2004 17:05:32 -0800, vpn-dub-055.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:672
Article PK: 862323

Which repagent are you referring to? The ASE repagent thread or the
heterogeneous repagent?
What platform are you on?

Thanks,
Wanda

<LNielsen> wrote in message news:407d582e.5fbb.846930886@sybase.com...
> We had a problem with our with repagent. The stable queue
> filled up and the server was shutdown. Now when we try to
> restart, we get the message that the port is in use.
>
> any ideas what we need to do to get the port freed?


lnielsen Posted on 2004-04-15 15:59:23.0Z
Sender: 7073.407ea2b9.1804289383@sybase.com
From: lnielsen
Newsgroups: sybase.public.rep-agent
Subject: Re: Server port <5552> is in use by another application.
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <407ea347.707c.846930886@sybase.com>
References: <407d582e.5fbb.846930886@sybase.com><407dd1cc$1@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 15 Apr 2004 07:59:19 -0800, 10.22.241.42
Lines: 23
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 15 Apr 2004 07:59:20 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 15 Apr 2004 07:59:23 -0800
X-Trace: forums-1-dub 1082041163 10.22.108.75 (15 Apr 2004 07:59:23 -0800)
X-Original-Trace: 15 Apr 2004 07:59:23 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:673
Article PK: 862324

The repagent is the heterogeneous one on Oracle. We are
running on Sun Solaris.

Thanks

Lyle


Which repagent are you referring to? The ASE repagent

> thread or the heterogeneous repagent?
> What platform are you on?
>
> Thanks,
> Wanda
>
> <LNielsen> wrote in message
> > news:407d582e.5fbb.846930886@sybase.com... We had a
> > problem with our with repagent. The stable queue filled
> > up and the server was shutdown. Now when we try to
> restart, we get the message that the port is in use. >
> > any ideas what we need to do to get the port freed?
>
>


Wanda Beck Posted on 2004-04-15 20:45:47.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.rep-agent
References: <407d582e.5fbb.846930886@sybase.com><407dd1cc$1@forums-1-dub> <407ea347.707c.846930886@sybase.com>
Subject: Re: Server port <5552> is in use by another application.
Lines: 56
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1409
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1409
X-Original-NNTP-Posting-Host: wbeckw2k.sybase.com
Message-ID: <407ee663@forums-2-dub>
X-Original-Trace: 15 Apr 2004 12:45:39 -0800, wbeckw2k.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 15 Apr 2004 12:45:40 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 15 Apr 2004 12:45:47 -0800
X-Trace: forums-1-dub 1082058347 10.22.108.75 (15 Apr 2004 12:45:47 -0800)
X-Original-Trace: 15 Apr 2004 12:45:47 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:675
Article PK: 862326

Hi, Lyle,

Sounds like the RepAgent may still be running -- probably in the background.
If you can't log into it, it's probably in a weird state. Since you're on
Solaris, just do a process status, either:
ps -ef
or
ps -aux
(whichever one works). Then, in all the entries, find the RepAgent
processes (given that RepAgent is in a weird state, you might find only
one). Below are the two that show up for my instance (ram_rat) of RepAgent
(where $SYBASE = /usr/u/wbeck/rax-12_5-sol):

wbeck 11928 11864 0 13:31:38 pts/3 0:00 /bin/sh ./ra -i ram_rat
wbeck 11929 11928 7 13:31:38 pts/3 0:04
/usr/u/wbeck/rax-12_5-sol/shared-1_0/jre1.2.2/bin/../bin/sparc/green_threads
/ja

You'll need to kill whatever you find running:

kill -9 11928 11929

Be sure you have the permission to kill. If you're not the user who started
the processes or can't su as that user, then you may need to be root.

Hope that helps.

Thanks,
Wanda

<lnielsen> wrote in message news:407ea347.707c.846930886@sybase.com...
> The repagent is the heterogeneous one on Oracle. We are
> running on Sun Solaris.
>
> Thanks
>
> Lyle
>
>
> Which repagent are you referring to? The ASE repagent
> > thread or the heterogeneous repagent?
> > What platform are you on?
> >
> > Thanks,
> > Wanda
> >
> > <LNielsen> wrote in message
> > > news:407d582e.5fbb.846930886@sybase.com... We had a
> > > problem with our with repagent. The stable queue filled
> > > up and the server was shutdown. Now when we try to
> > restart, we get the message that the port is in use. >
> > > any ideas what we need to do to get the port freed?
> >
> >