Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem returning blob

3 posts in Internet Developers Toolkit Last posting was on 2002-04-01 06:29:43.0Z
Andy Neagu Posted on 2002-03-29 10:03:23.0Z
Newsgroups: sybase.public.powerbuilder.inet-dev-toolkit
From: "Andy Neagu" <andy_neagu@hotmail.com>
Subject: Problem returning blob
Date: Fri, 29 Mar 2002 12:03:23 +0200
Lines: 54
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
NNTP-Posting-Host: 213.157.162.59
Message-ID: <388_CLzh1ow1BHA.216@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.inet-dev-toolkit:103
Article PK: 691266

Hi all,

This is the problem:

Using the pbisa70.dll (or pbcgi70.exe) when I return a blob instead of a
string in the browser display the results repeated "ad infinitum". Of
course, after a while the pb application crashes!

Example:

I have the x function that returns a blob, no parameters.

In it:



Blob lblb_blob;







Return blob("content-type: text/plain~r~n~r~ntest");



The result in the browser will be:

testcontent-type: text/plain
testcontent-type: text/plain
testcontent-type: text/plain
..

and so on until the application crushes or I'll stop the request!!!



I hope somebody knows what is going on here. It's quite urgent!!!



Andy N.



... hack to learn, don't learn to hack


Bruce Armstrong [TeamSybase] Posted on 2002-03-29 17:11:13.0Z
Newsgroups: sybase.public.powerbuilder.inet-dev-toolkit
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Organization: TeamSybase [12.13.238.140]
X-Newsreader: AspNNTP 1.50 (Advent 2000, Inc.)
Subject: Re: Problem returning blob
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Fri, 29 Mar 2002 12:11:13 -0500
Lines: 38
NNTP-Posting-Host: 207.156.232.111
Message-ID: <388_T#9n6S01BHA.153@forums.sybase.com>
References: <388_CLzh1ow1BHA.216@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.inet-dev-toolkit:102
Article PK: 691263

When you call a function through web.pb that returns a blob, web.pb will
keep calling the function until it returns a null. That's how web.pb knows
that it's got all the data. You might something as simple as:

blob lblb_null

SetNull ( lblb_null )

ii_call_count ++
IF ii_call_count > 1 THEN
RETURN lblb_null
ELSE
...the rest of your code....




On Fri, 29 Mar 2002 12:03:23 +0200,
in powersoft.public.powerbuilder.inet-dev-toolkit

Andy Neagu <andy_neagu@hotmail.com> wrote:
>Hi all,
>
>This is the problem:
>
>Using the pbisa70.dll (or pbcgi70.exe) when I return a blob instead of a
>string in the browser display the results repeated "ad infinitum". Of
>course, after a while the pb application crashes!
>
>Example:
>
>I have the x function that returns a blob, no parameters.
>
>In it:
>
>
>
>Blob lblb_blob;
>
>
>
>
>
>
>
>Return blob("content-type: text/plain~r~n~r~ntest");
>
>
>
>The result in the browser will be:
>
>testcontent-type: text/plain
>testcontent-type: text/plain
>testcontent-type: text/plain
>...
>
>and so on until the application crushes or I'll stop the request!!!
>
>
>
>I hope somebody knows what is going on here. It's quite urgent!!!
>
>
>
>Andy N.
>
>
>
>.... hack to learn, don't learn to hack
>
>
>
>
>
>

Bruce Armstrong [TeamSybase]
http://www.teamsybase.com
http://www.needhim.org

---== Posted via the PFCGuide Web Newsreader ==---
http://www.pfcguide.com/_newsgroups/group_list.asp


Andy Neagu Posted on 2002-04-01 06:29:43.0Z
Newsgroups: sybase.public.powerbuilder.inet-dev-toolkit
From: "Andy Neagu" <andy_neagu@hotmail.com>
Subject: Re: Problem returning blob
Date: Mon, 1 Apr 2002 09:29:43 +0300
Lines: 94
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
NNTP-Posting-Host: 213.157.162.59
Message-ID: <388_GGcTgfU2BHA.206@forums.sybase.com>
References: <388_CLzh1ow1BHA.216@forums.sybase.com> <388_T#9n6S01BHA.153@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.inet-dev-toolkit:101
Article PK: 691205

Thanks!!!!

Andy N.

... hack to learn, don't learn to hack ...



"Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>

wrote in message news:T#9n6S01BHA.153@forums.sybase.com...
> When you call a function through web.pb that returns a blob, web.pb will
> keep calling the function until it returns a null. That's how web.pb
knows
> that it's got all the data. You might something as simple as:
>
> blob lblb_null
>
> SetNull ( lblb_null )
>
> ii_call_count ++
> IF ii_call_count > 1 THEN
> RETURN lblb_null
> ELSE
> ...the rest of your code....
>
>
>
>
> On Fri, 29 Mar 2002 12:03:23 +0200,
> in powersoft.public.powerbuilder.inet-dev-toolkit
> Andy Neagu <andy_neagu@hotmail.com> wrote:
> >Hi all,
> >
> >This is the problem:
> >
> >Using the pbisa70.dll (or pbcgi70.exe) when I return a blob instead of a
> >string in the browser display the results repeated "ad infinitum". Of
> >course, after a while the pb application crashes!
> >
> >Example:
> >
> >I have the x function that returns a blob, no parameters.
> >
> >In it:
> >
> >
> >
> >Blob lblb_blob;
> >
> >
> >
> >
> >
> >
> >
> >Return blob("content-type: text/plain~r~n~r~ntest");
> >
> >
> >
> >The result in the browser will be:
> >
> >testcontent-type: text/plain
> >testcontent-type: text/plain
> >testcontent-type: text/plain
> >...
> >
> >and so on until the application crushes or I'll stop the request!!!
> >
> >
> >
> >I hope somebody knows what is going on here. It's quite urgent!!!
> >
> >
> >
> >Andy N.
> >
> >
> >
> >.... hack to learn, don't learn to hack
> >
> >
> >
> >
> >
> >
>
> Bruce Armstrong [TeamSybase]
> http://www.teamsybase.com
> http://www.needhim.org
>
> ---== Posted via the PFCGuide Web Newsreader ==---
> http://www.pfcguide.com/_newsgroups/group_list.asp