Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Deploy Javascript Becomes Dynascript

2 posts in PowerSite specific Last posting was on 2001-03-23 20:11:46.0Z
BrentL Posted on 2001-03-14 16:15:56.0Z
Newsgroups: sybase.public.powersite
From: BrentL
Date: Wed, 14 Mar 2001 11:15:56 -0500
Subject: Deploy Javascript Becomes Dynascript
Lines: 22
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <382_8F55D1E854FAEDA20059599985256A0F.005959AB85256A0F@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.powersite:255
Article PK: 862660

When doing a PowerSite deploy, I have button with an
onclick event using JavaScript. The deploy changes
the "language" tag to be "DynaScript". This means
that when fetched to a browser it doesn't know what to
do when the button is clicked because it doesn't know
what Dyascript is.

I am able to get around this by changing my Deploy
configuration to have Dynamo Deployment Center->
Transform->Transform Type set to None, rather than
Dynamo. This is only a temporary solution for this
one page.

Given that this is a simple page, with just
a button that does an onclick to open another page,
I don't think PowerSite should not be changing my l
anguage tag.

I would appreciate any insight into this issue.

Thanks,
Brent


Jackie Green Posted on 2001-03-23 20:11:46.0Z
Newsgroups: sybase.public.powersite
From: "Jackie Green" <jackie.green@sybase.com>
Subject: Re: Deploy Javascript Becomes Dynascript
Date: Fri, 23 Mar 2001 15:11:46 -0500
Lines: 39
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: jagreen-nt.sybase.com 204.167.46.207
Message-ID: <382_0igesg9sAHA.266@forums.sybase.com>
References: <382_8F55D1E854FAEDA20059599985256A0F.005959AB85256A0F@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powersite:246
Article PK: 840523

Hi Brent.

The PowerSite deployment controller looks through your page for server-side
script tags (for example <% %>), then converts then to the appropriate tag
for the application server you are deploying to. The controller does not
change client-side script tags (example <SCRIPT language=JavaScript>).

Check to be sure you are using a client-side tag for your client-side
scripts.

Cheers,
Jackie

<BrentL> wrote in message
news:8F55D1E854FAEDA20059599985256A0F.005959AB85256A0F@webforums...
> When doing a PowerSite deploy, I have button with an
> onclick event using JavaScript. The deploy changes
> the "language" tag to be "DynaScript". This means
> that when fetched to a browser it doesn't know what to
> do when the button is clicked because it doesn't know
> what Dyascript is.
>
> I am able to get around this by changing my Deploy
> configuration to have Dynamo Deployment Center->
> Transform->Transform Type set to None, rather than
> Dynamo. This is only a temporary solution for this
> one page.
>
> Given that this is a simple page, with just
> a button that does an onclick to open another page,
> I don't think PowerSite should not be changing my l
> anguage tag.
>
> I would appreciate any insight into this issue.
>
> Thanks,
> Brent