Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PowerSite, PowerDynamo DB connection

4 posts in PowerSite specific Last posting was on 2001-02-07 21:42:40.0Z
Wayne Wynn Posted on 2001-02-06 23:00:11.0Z
Newsgroups: sybase.public.powersite
From: wwynn@intergate.ca (Wayne Wynn)
Subject: PowerSite, PowerDynamo DB connection
Date: Tue, 06 Feb 2001 23:00:11 GMT
X-Newsreader: Forte Free Agent 1.11/32.235
Lines: 48
NNTP-Posting-Host: vanc01m02-76.bctel.ca 206.108.197.76
Message-ID: <382_3a808055.229811771@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powersite:296
Article PK: 862686

When we run the browser (IE5) on the home page of our intranet app, we
get error messages in all three frames. The message in the top frame
is below. We suspect that there is something not right in the ODBC
connection, but we have not determined what that might be. Another
frame gets a similar message with different details, and the third
uses Jaguar and a DW which is also not working. The first two frames
do not use DW's or Jaguar. Anyone got any ideas what to try to
correct this?

Warning: undefined variable connection near line 281 in "/menu.html"
Warning: undefined variable this.dynConn.CreateQuery[CreateQuery] near
line
246 in "/menu.html" Warning: undefined variable
this.dynConn.GetErrorCode[GetErrorCode] near line 248 in "/menu.html"
Warning: undefined variable this.dynConn.GetErrorInfo[GetErrorInfo]
near
line 248 in "/menu.html" Warning: undefined variable
newsCursor.GetValue[GetValue] near line 143 in "/menu.html" ????? {
CreateCommand=CreateCommand, CreateCursor=CreateCursor,
GetError=GetError,
AddError=AddError, ClearError=ClearError, errorObj={ code=1000,
info=Connection not found - using default, nextError=null,
GetCode=GetCode,
GetMessage=GetMessage, GetNextError=GetNextError }, dynConn={
name=TempWBRODatasa, description=Temporary Connection,
dataSource=WBROData,
server=null, database=null, userId=sa, password=null,
connectParameters=SRVR=W953E282;DB=WBRO;, dataSourceList={ MS Access
97
Database, Remedy ODBC Data Source, Visual FoxPro Database, Visual
FoxPro
Tables, ASA 6.0 Sample, ASA 6.0 Client Sample, pfc, peat, translat,
EAS Demo
DB V3 IM, PSMart, MQIS, Jaguar SVU Sample, Connect ODBC-OLE DB
Adapter, EAS
Demo DB V3, SurfSide Video DB, WBRO_ASE, WBRO_ASA, WBRO_A97, WBROData
},
databaseType=SQL Server, connectionType=ODBC, autoCommit=false,
simulateCursors=true, isolationLevel=ReadCommitted, connected=true } }


Larry Cermak [Team Sybase] Posted on 2001-02-07 00:15:21.0Z
Newsgroups: sybase.public.powersite
From: "Larry Cermak [Team Sybase]" <lcermak@ctpartners.com>
Subject: Re: PowerSite, PowerDynamo DB connection
Date: Tue, 6 Feb 2001 17:15:21 -0700
Lines: 64
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4133.2400
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
NNTP-Posting-Host: node-64-248-206-25.dslspeed.zyan.com 64.248.206.25
Message-ID: <382_PvY7PUJkAHA.166@forums.sybase.com>
References: <382_3a808055.229811771@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powersite:295
Article PK: 840538

<< Warning: undefined variable connection near line 281 in "/menu.html"

> Warning: undefined variable this.dynConn.CreateQuery[CreateQuery] near
> line
> 246 in "/menu.html" Warning: undefined variable
> this.dynConn.GetErrorCode[GetErrorCode] near line 248 in "/menu.html" >>

Take a look at your menu.html script and see what line 281 does.. Seems
like you are probably doing a site.GetConnection("connection_name") and it
cannot be found. Make sure that the web server was bounced after any
connections were created(mapped).


--

Larry Cermak [Team Sybase]
Corporate Technology Partners, Inc

Coming soon: Web DataWindow Book

Web DataWindow Articles: http://my.sybase.com/detail?id=1003371

"Wayne Wynn" <wwynn@intergate.ca> wrote in message
news:3a808055.229811771@forums.sybase.com...
> When we run the browser (IE5) on the home page of our intranet app, we
> get error messages in all three frames. The message in the top frame
> is below. We suspect that there is something not right in the ODBC
> connection, but we have not determined what that might be. Another
> frame gets a similar message with different details, and the third
> uses Jaguar and a DW which is also not working. The first two frames
> do not use DW's or Jaguar. Anyone got any ideas what to try to
> correct this?
>
> Warning: undefined variable connection near line 281 in "/menu.html"
> Warning: undefined variable this.dynConn.CreateQuery[CreateQuery] near
> line
> 246 in "/menu.html" Warning: undefined variable
> this.dynConn.GetErrorCode[GetErrorCode] near line 248 in "/menu.html"
> Warning: undefined variable this.dynConn.GetErrorInfo[GetErrorInfo]
> near
> line 248 in "/menu.html" Warning: undefined variable
> newsCursor.GetValue[GetValue] near line 143 in "/menu.html" ????? {
> CreateCommand=CreateCommand, CreateCursor=CreateCursor,
> GetError=GetError,
> AddError=AddError, ClearError=ClearError, errorObj={ code=1000,
> info=Connection not found - using default, nextError=null,
> GetCode=GetCode,
> GetMessage=GetMessage, GetNextError=GetNextError }, dynConn={
> name=TempWBRODatasa, description=Temporary Connection,
> dataSource=WBROData,
> server=null, database=null, userId=sa, password=null,
> connectParameters=SRVR=W953E282;DB=WBRO;, dataSourceList={ MS Access
> 97
> Database, Remedy ODBC Data Source, Visual FoxPro Database, Visual
> FoxPro
> Tables, ASA 6.0 Sample, ASA 6.0 Client Sample, pfc, peat, translat,
> EAS Demo
> DB V3 IM, PSMart, MQIS, Jaguar SVU Sample, Connect ODBC-OLE DB
> Adapter, EAS
> Demo DB V3, SurfSide Video DB, WBRO_ASE, WBRO_ASA, WBRO_A97, WBROData
> },
> databaseType=SQL Server, connectionType=ODBC, autoCommit=false,
> simulateCursors=true, isolationLevel=ReadCommitted, connected=true } }


Wayne Wynn Posted on 2001-02-07 21:42:40.0Z
Newsgroups: sybase.public.powersite
From: wwynn@intergate.ca (Wayne Wynn)
Subject: Re: PowerSite, PowerDynamo DB connection
Date: Wed, 07 Feb 2001 21:42:40 GMT
X-Newsreader: Forte Free Agent 1.11/32.235
Lines: 4
NNTP-Posting-Host: vanc01m01-28.bctel.ca 206.108.197.28
Message-ID: <382_3a81c0ce.311853371@forums.sybase.com>
References: <382_3a808055.229811771@forums.sybase.com> <382_PvY7PUJkAHA.166@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powersite:292
Article PK: 862682

We (another person) got this working. Dunno details. If someone reads
this case and wants them, email me.

wwynn____@intergate.ca (No "_ ")


Wayne Wynn Posted on 2001-02-07 01:36:42.0Z
Newsgroups: sybase.public.powersite
From: wwynn@intergate.ca (Wayne Wynn)
Subject: Re: PowerSite, PowerDynamo DB connection
Date: Wed, 07 Feb 2001 01:36:42 GMT
X-Newsreader: Forte Free Agent 1.11/32.235
Lines: 26
NNTP-Posting-Host: vanc01m02-82.bctel.ca 206.108.197.82
Message-ID: <382_3a80a56e.239309528@forums.sybase.com>
References: <382_3a808055.229811771@forums.sybase.com> <382_PvY7PUJkAHA.166@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powersite:294
Article PK: 862684

The menu.html that has 281 lines is generated at run time. We don't
know how to view it; perhaps you could tell us. The menu.html that is
coded is the one that comes up when we "view source" at run time. BTW
connect.ssc in the "system" subdirectory.appears to be o.k.

On Tue, 6 Feb 2001 17:15:21 -0700, "Larry Cermak [Team Sybase]"

<lcermak@ctpartners.com> wrote:

><< Warning: undefined variable connection near line 281 in "/menu.html"
>> Warning: undefined variable this.dynConn.CreateQuery[CreateQuery] near
>> line
>> 246 in "/menu.html" Warning: undefined variable
>> this.dynConn.GetErrorCode[GetErrorCode] near line 248 in "/menu.html" >>
>
>Take a look at your menu.html script and see what line 281 does.. Seems
>like you are probably doing a site.GetConnection("connection_name") and it
>cannot be found. Make sure that the web server was bounced after any
>connections were created(mapped).
>
>
>--
>
>Larry Cermak [Team Sybase]
>Corporate Technology Partners, Inc